Ir para: navegação, pesquisa

Speedr/Manual/Mikrotik/Cache Full

< Speedr‎ | Manual‎ | Mikrotik

Neste tópico iremos abordar a configuração do Cache Full Simples e Personalizado junto ao Mikrotik.

A configuração do cache full requer alguns conhecimentos básicos no RouterOS, caso tenha alguma dificuldade, recomendamos que algum técnico faça essa configuração.


Cache Full Simples

O Cache Full Simples, possibilita determinar uma velocidade para cada cliente.


IP > Firewall > Mangle

No mangle vamos configurar quatro regras, três marcações de conexões e uma marcação de pacote.

Para adicionar clique no botão: (MikrotikBotaoAdd.png)

  • Aba General >
    • Chain: postrouting
  • Aba Advanced >
    • DSCP (TOS): 10
  • Aba Action >
    • Action: mark connection
    • New Connection Mark: HitSpeedr
    • Passthrough: Yes
MikrotikIpFirewallMangleCFS1.png

Clique novamente no botão: (MikrotikBotaoAdd.png)

  • Aba General >
    • Chain: postrouting
  • Aba Advanced >
    • DSCP (TOS): 12
  • Aba Action >
    • Action: mark connection
    • New Connection Mark: HitSpeedr
    • Passthrough: Yes
MikrotikIpFirewallMangleCFS2.png

Clique novamente no botão: (MikrotikBotaoAdd.png)

  • Aba General >
    • Chain: postrouting
  • Aba Advanced >
    • DSCP (TOS): 48
  • Aba Action >
    • Action: mark connection
    • New Connection Mark: HitSpeedr
    • Passthrough: Yes
MikrotikIpFirewallMangleCFS3.png

Clique novamente no botão: (MikrotikBotaoAdd.png)

  • Aba General >
    • Chain: postrouting
    • Connection Mark: HitSpeedr
  • Aba Action >
    • Action: mark packet
    • New Packet Mark: CacheFull
    • Passthrough: No
MikrotikIpFirewallMangleCFS4.png
  • Ao término das configurações clique em OK.
Regras:
/ip firewall mangle
add action=mark-connection chain=postrouting dscp=10 new-connection-mark=HitSpeedr
add action=mark-connection chain=postrouting dscp=12 new-connection-mark=HitSpeedr
add action=mark-connection chain=postrouting dscp=48 new-connection-mark=HitSpeedr
add action=mark-packet chain=postrouting connection-mark=HitSpeedr new-packet-mark=\
    CacheFull passthrough=no


Queue > Queue Types

Aqui será configurar uma Queue em PCQ, pois ela será responsável por entregar a banda determinada a cada cliente.

Para adicionar clique no botão: (MikrotikBotaoAdd.png)

  • Type Name: CacheFull
  • Kind: pcq
  • Rate: 5m (velocidade desejada por cliente)
MikrotikQueueQueueTypesCFS1.png
  • Ao término das configurações clique em OK.
Regras:
/queue type
add kind=pcq pcq-classifier=dst-address name=CacheFull pcq-rate=5M


Queue > Simple Queues

Atenção nessa Queue, ela deverá ser a sua primeira regra, pois caso ela esteja abaixo das demais Queue, o Cache Full não vai funcionar.

Para adicionar clique no botão: (MikrotikBotaoAdd.png)

  • Aba General >
    • Name: Cache Full
    • Target: 0.0.0.0/0
  • Aba Advanced >
    • Packet Marks: CacheFull (aqui utilizamos a marcação do pacote feita na quarta regra do mangle)
    • Queue Type: CacheFull (aqui vamos utilizar a Queue Type criada anteriomente)
MikrotikQueueSimpleQueueCFS1.png
  • Ao término das configurações clique em OK.
Regras:
/queue simple
add name=CacheFull packet-marks=CacheFull queue=CacheFull/CacheFull target="0.0.0.0/0"


Cache Full Personalizado

O Cache Full Personalizado, possibilita determinar uma velocidade diferente para cada plano oferecido.

PPP > Profiles

Atenção: Se já utiliza algum sistema de gerenciamento que crie as Address List dinamicamente, pule essa parte.

Em PPP vamos determinar que o Mikrotik gere automaticamente as Listas de Endereços IP, no exemplo abaixo vamos configurar três Address List, uma para cada plano, caso necessite de mais, basta seguir o modelo ex: Address List: Profile4MB.


Abra o profile 1Mega

  • Aba General >
    • Address List: Profile1MB


Abra o profile 2Mega

  • Aba General >
    • Address List: Profile2MB


Abra o profile 3Mega

  • Aba General >
    • Address List: Profile3MB
MikrotikPPP-ProfilesCFP1.png
  • Ao término das configurações clique em OK.
Regras:
/ppp profile
add address-list=Profile1MB name=1Mega rate-limit=128k/1m
add address-list=Profile2MB name=2Mega rate-limit=256k/2m
add address-list=Profile3MB name=3Mega rate-limit=384k/3m


IP > Firewall > Mangle

Vamos utilizar seis regras no mangle, três marcações de conexões e três marcações de pacotes, um pacote para cada plano disponível, caso tenha mais planos, basta adicionar mais marcações de pacotes.

Para adicionar clique no botão: (MikrotikBotaoAdd.png)

  • Aba General >
    • Chain: postrouting
  • Aba Advanced >
    • DSCP (TOS): 10
  • Aba Action >
    • Action: mark connection
    • New Connection Mark: HitSpeedr
    • Passthrough: Yes
MikrotikIpFirewallMangleCFS1.png

Clique novamente no botão: (MikrotikBotaoAdd.png)

  • Aba General >
    • Chain: postrouting
  • Aba Advanced >
    • DSCP (TOS): 12
  • Aba Action >
    • Action: mark connection
    • New Connection Mark: HitSpeedr
    • Passthrough: Yes
MikrotikIpFirewallMangleCFS2.png

Clique novamente no botão: (MikrotikBotaoAdd.png)

  • Aba General >
    • Chain: postrouting
  • Aba Advanced >
    • DSCP (TOS): 48
  • Aba Action >
    • Action: mark connection
    • New Connection Mark: HitSpeedr
    • Passthrough: Yes
MikrotikIpFirewallMangleCFS3.png

Clique novamente no botão: (MikrotikBotaoAdd.png)

  • Aba General >
    • Chain: postrouting
    • Connection Mark: HitSpeedr
  • Aba Advanced >
    • Dst. Address List: Profile1MB
  • Aba Action >
    • Action: mark packet
    • New Packet Mark: CacheFullProfile1MB
    • Passthrough: No
MikrotikIpFirewallMangleCFP1.png

Clique novamente no botão: (MikrotikBotaoAdd.png)

  • Aba General >
    • Chain: postrouting
    • Connection Mark: HitSpeedr
  • Aba Advanced >
    • Dst. Address List: Profile2MB
  • Aba Action >
    • Action: mark packet
    • New Packet Mark: CacheFullProfile2MB
    • Passthrough: No
MikrotikIpFirewallMangleCFP2.png

Clique novamente no botão: (MikrotikBotaoAdd.png)

  • Aba General >
    • Chain: postrouting
    • Connection Mark: HitSpeedr
  • Aba Advanced >
    • Dst. Address List: Profile3MB
  • Aba Action >
    • Action: mark packet
    • New Packet Mark: CacheFullProfile3MB
    • Passthrough: No
MikrotikIpFirewallMangleCFP3.png
  • Ao término das configurações clique em OK.
Regras:
/ip firewall mangle
add action=mark-connection chain=postrouting dscp=10 new-connection-mark=HitSpeedr
add action=mark-connection chain=postrouting dscp=12 new-connection-mark=HitSpeedr
add action=mark-connection chain=postrouting dscp=48 new-connection-mark=HitSpeedr
add action=mark-packet chain=postrouting connection-mark=HitSpeedr dst-address-list=\
Profile1MB new-packet-mark=CacheFullProfile1MB passthrough=no
add action=mark-packet chain=postrouting connection-mark=HitSpeedr dst-address-list=\
Profile2MB new-packet-mark=CacheFullProfile2MB passthrough=no
add action=mark-packet chain=postrouting connection-mark=HitSpeedr dst-address-list=\
Profile3MB new-packet-mark=CacheFullProfile3MB passthrough=no

Queue > Queue Types

Diferente da configuração simples, no personalizado vamos criar uma Queue Type para cada plano.

Para adicionar clique no botão: (MikrotikBotaoAdd.png)

  • Type Name: CacheFullProfile1MB
  • Kind: pcq
  • Rate: 2m (velocidade desejada por cliente)


Clique novamente no botão: (MikrotikBotaoAdd.png)

  • Type Name: CacheFullProfile2MB
  • Kind: pcq
  • Rate: 4m (velocidade desejada por cliente)


Clique novamente no botão: (MikrotikBotaoAdd.png)

  • Type Name: CacheFullProfile3MB
  • Kind: pcq
  • Rate: 6m (velocidade desejada por cliente)
MikrotikQueueQueueTypesCFP1.png
  • Ao término das configurações clique em OK.
Regras:
/queue type
add kind=pcq name=CacheFullProfile1MB pcq-classifier=dst-address pcq-rate=2M
add kind=pcq name=CacheFullProfile2MB pcq-classifier=dst-address pcq-rate=4M
add kind=pcq name=CacheFullProfile3MB pcq-classifier=dst-address pcq-rate=6M


Queue > Simple Queues

Seguindo o raciocínio da Queue Type, aqui também será criada uma regra para cada plano.

Atenção, todas a regras que serão adicionadas deveram ser as primeiras regras, pois caso fiquem abaixo das demais Queue, o Cache Full não vai funcionar.

Para adicionar clique no botão: (MikrotikBotaoAdd.png)

  • Aba General >
    • Name: Cache Full 1Mega
    • Target: 0.0.0.0/0
  • Aba Advanced >
    • Packet Marks: CacheFullProfile1MB
    • Queue Type: CacheFullProfile1MB
MikrotikQueueSimpleQueueCFP1.png

Clique novamente no botão: (MikrotikBotaoAdd.png)

  • Aba General >
    • Name: Cache Full 2Mega
    • Target: 0.0.0.0/0
  • Aba Advanced >
    • Packet Marks: CacheFullProfile2MB
    • Queue Type: CacheFullProfile2MB
MikrotikQueueSimpleQueueCFP2.png

Clique novamente no botão: (MikrotikBotaoAdd.png)

  • Aba General >
    • Name: Cache Full 3Mega
    • Target: 0.0.0.0/0
  • Aba Advanced >
    • Packet Marks: CacheFullProfile3MB
    • Queue Type: CacheFullProfile3MB
MikrotikQueueSimpleQueueCFP3.png
  • Ao término das configurações clique em OK.
Regras:
/queue simple
add name=CacheFullProfile1MB packet-marks=CacheFullProfile1MB queue=\
    CacheFullProfile1MB/CacheFullProfile1MB target="0.0.0.0/0"
add name=CacheFullProfile2MB packet-marks=CacheFullProfile2MB queue=\
    CacheFullProfile2MB/CacheFullProfile2MB target="0.0.0.0/0"
add name=CacheFullProfile3MB packet-marks=CacheFullProfile3MB queue=\
    CacheFullProfile3MB/CacheFullProfile3MB target="0.0.0.0/0"